TEACHER'S HANDBOOK

COMPUTER
Backs(6)

KEYS

FRANKILIN




COMPUTER

Ch-1()
A. 1.programming 2. Electronic signal 3. machine
4. mnemonics 5. Off-stage, On stage
B. l.machine language 2. COBOL 3.C++ 4.SQL 5. Prolog
C. 1T 2.F 3.F 4.7 5.F

D. 1.Machine Language is expressed in binary form. This language has very high speed
and very low memory utilization. But understanding it is difficult and a bit time
consuming. It is highly dependent on the machine, which is why it is also regarded

as a Low-Level language.

2. Compiler Interpreter
A compiler converts the An interpreter translates line by line, carries
programming code written out the instructions, and then repeats the
in a high-level language procedure for the remaining instructions.

into machine language.

3. High-Level Language Assembly Language
User-friendly. Symbols or mnemonic codes are used in this|
Machine-independent. language in place of 0 and 1.

Machine-dependent

4.  The features of the fourth-generation language are as follows:
1. High speed of execution.
2. Highly user-friendly and designed to reduce the level of programming efforts.
3. In this language, the user has to mention only the output required, while the
computer regulates the sequence of instructions that will achieve those results.
5. The advantages of learning a program are
1. It develops Analytical Thinking
2. It enhances creativity.

3. Programming develops reasoning skills.

Critical Thinking

Generation Popular Programming Languages
First Generation Languages Machine Language
Second Generation Languages FORTRAN, COBOL and ALGOL
Third Generation Languages FORTRAN, Pascal and the C-family C++
Fourth Generation Languages Perl, Python, Ruby, SQL, MatLab
Fifth Generation Languages Mercury, Prolog, OP55
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Team Work

Machine Language: This language is expressed in binary form, i.e., 0 and 1, where 0
means 'off '; this is to signify a stage where the current is not flowing in the
electronic computer units. The other stage is 1, the 'On' stage, which signifies the

current flowing within the computer circuit.

Fortran is a general-purpose, programming language that is especially suited to

numeric computation and scientific computing.

C++ is a high-level general-purpose programming language created by Danish
computer scientist Bjarne Stroustrup as an extension of the C programming

language, or "C with Classes".

Python is a high-level, general-purpose programming language.

Mercury is a pure logic programming language intended for the creation of large,

fast, reliable programs.

Ch-2 ()
A. 1. presentation 2. mathematical 3. equation editor 4. screen recording
5. liveliness
B. 1F 2.T 3.T 4.T S.images T
C. 1. Insert 2. Stop to save 3. Symbols
4. Sound card, microphone, speakers 5.Format tool tab
D. 1.Steps:

1. Click on the Insert Tab.

2. In the images group, click on the photo album drop-down menu.

3. Click on the New Photo album option. The Photo Album dialogue box appears.

4. In the insert picture from a section, choose the File/Disk tab to select pictures
from your computer. The Insert New pictures dialogue box appears.

5. Browse and navigate to the desired location to select as many as you want, to
make your photo album. Under the pictures in the album box, the pictures that
you select will be added.

6. Now, go to the Album Layout section and select picture layout, frame shape and
theme accordingly.

7. Click on create button. Your photo album presentation is ready.

2. Follow the given steps to insert a video clip onto a slide.

Steps:

1. Click on the Insert tab.

2. In the Media group, click on the video drop-down and select the This PC option.

3. The insert video dialogue box appears. Navigate to the location and select the

desired video, then click on insert.

4. Once the video is inserted, you can change the video shape, border effect, styles

and much more in the video Format option.

5. Click on the Play button below the video clip.
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Follow the given steps to move videos on aslide.

Steps:

1. Select the video.

2.Move the video by dragging it to the new location or press the arrow keys to move the
video by small amounts.

You can quickly include mathematical equations in your presentation by using the ink
equation tool.

Screen recording is one of the features of PowerPoint which allows recording computer
screens with audio. Follow the given steps foradding a screen recording in
PowerPoint.

Steps:

1. Select the slide where you want to record the screen recording.

2. Click on the Insert tab and in the Media group, click the screen recording option.

3. Click on the select area button.

4. Drag the mouse over the desired region of the screen you want to record.

5. Click on the record button if you want to add audio to the recording.

Critical Thinking

Follow the given steps to resize the video on the slide.

Steps:

1. Select the video.

2.Resizing handles appear around the border of the video. 3. Drag any corner in or out
as per the requirement.

Teamwork

Students will do it themselves

Ch-3 ()

1.Backspace 2. formats 3. AutoFill 4= 5.arrow
1.T 2.F 3.F 4.T 5.F
1. Home 2.Alt+Enterkey  3.Ctrl+ Spacebar 4. Arrow Keys
5.EditMode
L

Page Up Page Down
To move one screen up, we can To move one screen down, we can
press the press the
Page Up key. Page Down key.

The AutoFill feature fills in a series of data in your worksheet automatically.

The end key will move the insertion point to the right of the cell content if edit mode
is on.

Follow the given steps to edit a cell in the worksheet. Steps: 1. Click on the cell you

want to edit. 2. Double-click in the cell or press the F2 Key. 3. Erase the cell data. 4.

Type the new data. 5. Press the Enter Key.

There are two methods to copy a formula: the Fill Handle, Copy and Paste.
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Critical Thinking

AutoFill feature automatically fills a series of data in your worksheet. Follow the
given steps to create a list using an auto-fill feature. Steps: 1. Enter the first two
values you want to start the series with. 2. Select both the cells in which you have
entered the data. 3. Position the mouse pointer over the bottom right corner of the
last selected cell. Observe how the pointer changes to the (+) sign.4. Drag the mouse
to where you want the series.5. Observe the cells filled with the desired values.
Team Work

Students will do it themselves

Ch-4()
A. 1.Relationship 2.Three 3. Arithmetic 4.address
5.relative and absolute
B. L.F 2.T 3. 4.T 5.T

C. 1.Functions are predefined formulas in Excel to perform simple and complex
calculations. Functions eliminate the chance to write incorrect formulas.
2. Acellreference is a cell address that can be used in a formula to denote a specific cell.
3. Symbols that mention the operation to be performed
4. Numbers or text values that do not change.
5. Anexpression that compares two or more numbers, text strings, cell contents, or
function outputs is known as a comparison formula.
D. 1.Enter Mode: This mode appears when you type the equal sign to begin the formula. It
is the mode you use to enter text
PointMode:  When we press any navigation key on the keyboard, Excel enters Point
Mode. This is the mode you use to select a cell or range as a formula
operand.
Edit Mode: Excel enters Edit modewhenwe pressthe F2 key. This is the mode you use
to make changes to formula
2. Whena formulais copied from one cell to another cell, the value in the copied cell
automatically gets changed.
3. Rulesto EnteraFunction
- All Excel functions must begin with =sign.
+ The function name must be a valid Excel name.
- Open and close parenthesis must be placed after the function.
- Arguments must be enclosed in Parentheses.
4. Follow the given steps to calculate the average.
Steps:
1. Click on the cell where you want to place the average of the values. Letus say C11
Sheet 1.
2. Select the Insert Function button on the Formulas tab to open the Insert Function
dialogue box.
3. Select Average from the list box, and click on the Ok button.
5.Amixedreference is a combination of relative and absolute references. Either arow
orlocked by preceding it with a dollar symbol.
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2.The pen block presents as an extension to the Scratch 3.0
3. The different blocks available in Scratch are Sound Block, Motion Block, Control
Block, Events Block, and Pen Block
4. 1. Click the sound block.
2. Select the play sound meow until done and drag this block and place it under the
Script Palette.
3. Run the code by clicking on the blocks in the Script area.
4.To stop all sounds being played on all sprites, use the stop all sounds block.
5.Follow the given steps to choose a backdrop for the sprite.
Steps: 1. Click on the Choose a Backdrop button.
2.Choose a Backdrop window appears.
3. From the preview list, select the Blue Sky backdrop. The Blue Sky backdrop at
the background of the Sprite will be added.

Critical Thinking
Students will do it themselves
Team Work
The students will do it themselves.
Ch-5(
1. programming 2. pattern 3.Computational thinking
4. patterns and sequences 5. reasoning
1.F 2F 8. T 4.F 5.T
1.Decomposition 2.Pattern recognition 3.Pattern Abstraction

4. Algorithm design 5. Computational thinking

1. Computational thinking is the process of breaking down a problem into simple
enough steps.

Computational thinking logically segments a problem into smaller segments. Itis a
method of problem-solving that aids the user in comprehending, interpreting, and
resolving issues.

There are four key skills in computational thinking: 1 Decomposition 2Pattern
Recognition

3 Pattern Abstraction 4 Algorithm Design

Algorithm design is the process of laying out the steps and rules that must be followed
in order to achieve the desired result.

The process of pattern identification is crucial in computational thinking since it allows
the user to find solutions more quickly. Once a problem is broken down, discovering
patterns in the broken parts simplifies work.

Critical Thinking
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Team Work

The students will do it themselves.

Ch-6 ()
1. open-source 2. Internet 3.two 4.Individual 5. Title Bar
1.T 2.T 3.F 4.F 5.F
3 4 2 5 1

1. Pythonis an open-source programming language, which implies that anyone who is

versed in Python is capable of creating new programs and adding them to the available

Python libraries.

2.The features of Python:

e Pythonis freely available on the internet and can be easily downloaded from www.
Python.org.

e Python is portable and platform-independent means it can run on various
operating systems and hardware platforms.

The component of the Python Window:

e Title Bar: The names of the application and the document are displayed here.
Command buttons like Minimise, maximise, restore and close are presented here.

e Menu Bar: Various tabs such as File, Edit, Shell, Debug, Windows and Help are
displayed here.

e  Script Area: The area where you type the code. Status Bar: Current status of your
cursor is displayed here.

The steps touse the script mode in Python:

1. Start Python IDLE.

2. Click New on the File menu.

3. Type the commands in the window that opens.

4. Click on save on the File menu.

5. Name the file with the .py extension.

Interactive Mode Script Mode
Interactive mode is where you type Script mode is where you put a bunch of
commands and they are immediately commands into a file (a script), and then
executed. tell Python to run the file.
Critical Thinking
1. Script Area 2. Title Bar 3. Status Bar 4. Menu Bar
Team Work

1. Python Developed by Guido van Rossum
2. JavaScript developed by Netscape

3. C++ developed by Dennis Ritchie

4. PHP Developed by Guido van Rossum
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Ch-7()
1.Hypertext Markup Language 2. Tim Berners-Lee 3. independent
4.Tags 5. Attributes
L.F 2.F 3.F 4.F 5.T
1.Tags 2.Markup Language 3.HTML 4. markup tags
5.Block Level Tags
1. The HTML file is a text document that contains markup tags. The markup tags
instruct the web browser on how to display the webpage.
2. Container Tags, Empty Tags, Block Level Tags, Text Level Tags
3. Inorderto write HTML codes, we need to abide by some rules. These are:
1. Tags should always be surrounded by angle brackets. <>
2. Values given to the attributes should be enclosed in double-quotes.
4. The three terminologies related to HTML: Hypertext, Markup Language, Tags
5.Empty Tags: A tag that only contains an open tag and no closing tag is called an Empty
Tag. For Example: Eand many more.
Critical Thinking
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Team Work:
www.youtube.com- c++
www.google.com-PHP
www.facebook.com- Python

www.twitter.com-Java
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Ch-8()
A. 1Al 2.machine learning 3.Weak Al and Strong Al 4.first  5.Robots
1.F 2.T 3T 4.T 5.F
C. l.rotelearning 2.SHRDLU 3. Perception 4.Voice Assistant
5.Face Detection
D. 1.Theintelligence demonstrated by a machine is known as Al

2

Weak Al Strong Al

Weak Al alsoknownasnarrow Al isartificial | Strong Al is widely used, and the scope is
intelligence with limited functionality. vast.

It is good at specific tasks. It has incredible human-level intelligence.

3. Avoice assistant is a kind of Al software that can comprehend and carry out human
spoken orders. Examples: Google Assistant, Cortana, Siri and Alexa. Face detection is
an Al technology used for various purposes. We use face detection for filters on the face
while taking pictures and face ID for unlocking the phone.

4. Worldwide, businesses and organisations invest a significantamount of money in
customer care and put in a lot of effort to give their clients ongoing assistance. Many
companies have built chatbots to provide customer support that use Natural Language
Processing to answer questions about their products and services.

5.1.Banking and Financial Systems: Banks and other financial organisations create
Smart Apps to assist consumers with check deposits, fraud detection, etc., using Al
technologies.

2. Space Research: Artificial intelligence facilitates satellite communications and
extracts the maximum value from the images, increasing our understanding of space.
Critical Thinking

Navigation apps, estimated time, Google Maps

TeamWork

Al helps students get personalised answers to relevant questions from teachers. It also
helps educate students according to the issues and questions they face in class materials
and online sessions. Students now have access to a larger system for interacting with

professors.
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Ch-9(

A. 1.E-mail 2.Voice-Over-Internet Protocol 3. video conferencing
4. Network Etiquettes 5.Cheques
B. LT 2.F 3T 4T 5T
C. 1.Netiquettes 2.VoIP 3.social networking website
4.E-Greetings 5.Facebook
D. [I.hisrefersto fraud in which scanners are used to steal the electronic serial numbers of
cellular phones, which can be utilised for billing purposes and making broadcast calls.
2. Cyber security is the practice of defending computers, servers, mobile devices,
electronic systems, networks, and data from malicious attacks.
3. E-mail, Video Conferencing, Voice-Over-Internet Protocol (VoIP), and social3
networking are different types of communication techniques.
4.
E-greeting Paper Greeting
E-greetings are in soft copy Paper greeting cards are in hard copy.
5.Data diddling, phishing, and cloning are three types of cyber threats.
Critical Thinking
A/H|(E|B|/A|N K|I|N|G|O I]|P
RIBICIA|S|IDIF|[G|O|(H|J|[K|L
(=)
D FID|IE||CIVIBINIM|A|P|V|S
Clo|M|M|U|N|T|CIA|T|I|O|N
Q|E|E|A||R|T|Y|Y|J|F|V]|I]|O
S|D|F||I[]|G]|O FIG|IK|L|P|D
Q|W|E|LJE|G|R|EJE|T|I|N]|G)
Team Work
Students will do it themselves
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